Utiliser (tidy) HTML Validator sur Ubuntu Lucid 10.04


J’utilisais l’extension de Firefox Tidy HTML Validator jusqu’à ce qu’elle ne fonctionne plus avec les versions packagées par Ubuntu.

HTML Validator est une extension Mozilla qui ajoute une validation HTML dans Firefox et Mozilla. Le nombre d’erreurs d’une page HTML est visible sur la forme d’ une icône dans la barre d’état lorsque vous naviguez. Les détails des erreurs sont vu quand on regarde la source HTML de la page.

L’extension est basée sur Tidy et OpenSP . Les deux algorithmes ont été élaborés par le Web Consortium W3C . Et maintenant étendus et améliorés par un grand nombre de personnes. Les deux algorithmes sont intégrés à l’intérieur de Mozilla / Firefox et permettent la validation en local sur votre machine, sans envoyer de HTML à un serveur tiers.

Mais depuis quelques temps, je dois de nouveau me plonger dans la création de sites, et elle me manquait. Donc je me suis penché sur les solutions nécessaires pour l’utiliser.

Puis finalement, sans trop savoir le pourquoi du comment, j’ai réussi à la faire fonctionner. J’ai reproduit avec succès l’installation sur deux autres ordinateurs et je vous livre ici la méthode pour la Lucid Lynx en 32 bits.

HTML validator est compilé pour utiliser la librairie libstdc++5. Or, sur Ubuntu, ce n’est pas la dernière version existante (c’est la libstdc++6).Si vous essayez d’installer directement l’extension, vous aurez le message d’erreur suivant:

error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

Installation de la librairie libstdc++5 sur Ubuntu

La première chose à faire est de trouver cette librairie et de l’installer. Pas de chance, les liens vers les sites Ubuntu des anciennes versions proposant cette librairie sont morts, mais heureusement, on peut la trouver chez Debian et l’installer sans problème. J’ai utilisé la version Lenny (stable)/ i386 sur le miroir ftp.de.debian.org/debian

Installation des paquets supplémentaires

Certains paquets seront nécessaire par la suite, ajoutons les directement, cela évitera les problèmes de dépendances:

apt-get install libosp5 libnspr4-dev

Il faudra aussi modifier le fichier /etc/profile pour ajouter la ligne suivante en toute fin de fichier:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH/usr/lib/xulrunner/

Ensuite, fermez votre session et reconnectez vous pour que cela soit pris en compte.

Installation des éléments nécessaires au module HTML Validator

Quelqu’un a eu la bonne idée de packager les différents éléments nécessaires au fonctionnement du module, et de les mettre sur un PPA. Par contre, impossible d’utiliser le ppa, il ne liste pas les paquets qui nous intéressent… Mais on peut y accéder directement en suivant cette adresse.

Installez les paquets « data » et html-validator pour votre version. Dans mon cas: htmlvalidator-data_0.8.5.8+svn65-0ubuntu1~ppa1_all.deb et htmlvalidator_0.8.5.8+svn65-0ubuntu1~ppa1_i386.deb. Vous pouvez les télécharger et les installer en ligne de commande, ou le faire graphiquement, tant que vous commencez par le paquet « data ».

Installation du module

Si tout est présent, en redémarrant Firefox, vous verrez le module présent dans la liste des modules. Mais il vous dira que ce module n’est pas compatible avec la version de Firefox. Dommage…

Rassurez vous, les éléments nécessaires au fonctionnement sont installés. Il suffit maintenant d’aller sur le site de l’extension et de télécharger le module pour Firefox, et de l’installer normalement.

Redémarrez Firefox, et le module sera opérationnel.

Les idées sur lesquelles je ne me suis pas penché

Tout simplement parce que la méthode ci dessus fonctionne. Ce n’est peut être pas le plus propre, mais je manque de temps pour tout défricher.

  • Si on faisait croire à Firefox que la libstdc++6 est la libstdc++5 en créant un lien adéquat? Je ne connais pas les différences entre les deux versions.
  • Peut on utiliser wine pour faire tourner Firefox win32 et l’extention Tidy HTML Validator ?
  • Contacter le mainteneur du PPA pour savoir pourquoi il ne liste pas les paquets html-validator et s’il peut corriger ceux ci pour qu’il ne soit plus nécessaire d’installer l’extention par la suite (et suivre les mises à jour avec le gestionnaire des paquets)
  • Contacter le mainteneur de l’extention Tidy HTML Validator pour lui soumettre la méthode, et voir s’il peut proposer une extension directement compatible avec Ubuntu.

Si vous avez du temps…

Articles en relation:

  1. 13 mars 2011 à 13:40:37 | #1

    Bonjour,

    Tuto très bien agencé pour retrouver le module excellent HTML-Validator par contre les liens ppa n’existent plus ! :/

    J’avais trouvé une autre solution pour mon propre PC. Si je la retrouve, je vous la communique 😉

  2. 13 mars 2011 à 13:44:03 | #2

    Ha ba, en téléchargeant la version 0.861 : http://users.skynet.be/mgueury/mozilla/download.html
    ça marche 🙂

    Merci à vous pour ce bon tuto 😉

  3. 1 mai 2011 à 20:44:46 | #3

    Merci ! Je n’ai pas tout compris (car je suis débutante sur ubuntu), je n’ai pas pu ouvrir tous les liens indiqués mais ……… ça a fonctionné ! Merci donc.

  1. Pas encore de trackbacks

Anti-Spam Quiz:

antibot * Time limit is exhausted. Please reload the CAPTCHA.

54.198.23.251