Ubuntu: faire fonctionner la carte Ethernet Atheros AR8151

Ethernet controller [0200]: Atheros Communications AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)

Les derniers pilotes Athéros ne sont pas disponibles. Le serveur semble down ou cassé, mais il est possible d’installer les drivers pour faire fonctionner cette carte réseau grâce à un forum allemand.

Installons d’abord les éléments nécessaires

sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential

Nous allons ensuite installer DKMS pour installer le module

sudo apt-get install --reinstall linux-headers-$(uname -r) build-essential dkms        # s'ils ne sont pas déjà installés
## Pour Ubuntu 10.04
wget http://media.cdn.ubuntu-de.org/forum/attachments/2666793/AR81Family-linux-v1.0.1.14_dkms.tar.gz
sudo tar xvf AR81Family-linux-v1.0.1.14_dkms.tar.gz -C /usr/src

# Pour Ubuntu 10.10 et supérieur
wget http://media.cdn.ubuntu-de.org/forum/attachments/2666793/AR81Family-linux-v1.0.1.14_10.10.tar.gz
sudo tar xvf AR81Family-linux-v1.0.1.14_10.10.tar.gz -C /usr/src

Création du module et installation

sudo dkms add -m atl1e -v 1.0.1.14
sudo dkms build -m atl1e -v 1.0.1.14
sudo dkms install -m atl1e -v 1.0.1.14

Chargement du module et test

sudo modprobe atl1e
dmesg | egrep 'atl1e|eth'
ifconfig -a

Malheureusement, l’archive pour 10.10 et supérieurs n’est plus disponible sur ce site. Je met donc au moins l’archive pour 10.04 à disposition sur le mien au cas où elle disparaitrait

AR81Family-linux-v1.0.1.14_dkms.tar

Source: http://forum.ubuntuusers.de/topic/lan-geht-nicht-wlan-schon/#post-2666793

Articles en relation:

  1. David Froger
    27 décembre 2011 à 18:48:04 | #1

    Je viens de faire l’acquisition d’un Packard Bell EasyNote LS qui possède cette carte éthernet.

    La carte éthernet fonctionne directement sous Ubuntu 11.04.

    En revanche, elle ne fonctionnait pas sur Ubuntu 10.04. Après avoir suivi les instruction ci-dessous, elle fonctionne maintenant très bien.

    Donc un grand merci pour ces explications.

    Au passage, il y a deux lignes de html qui ne sont pas bien rendus (les deux lignes de commandes wget).

    Merci encore et joyeuses fêtes!

  2. 1 janvier 2012 à 18:15:41 | #2

    @ David Froger
    Commandes wget corrigées. Merci.

  3. tidiani
    28 juin 2012 à 18:24:26 | #3

    Bonjour monsieur Froger.J’ai un packardbell Easynote TM 94 qui était en version espagnole.depuis qu’elle fut désinstallée le pc a perdu ses pilotes webcam,ethernet et seul le wifi marche,le bluetooth.Que faire pour retrouver les pilotes perdues.Merci

  4. kameli omar
    23 octobre 2012 à 15:02:21 | #4

    Bonjour monsieur J’ai un packardbell Easynote TM 94 depuis qu’elle fut désinstallée le pc a perdu ses pilotes webcam,ethernet et seul le wifi marche,le bluetooth.Que faire pour retrouver les pilotes perdues.Merci

  5. 11 décembre 2012 à 17:20:18 | #5

    Merci pour le tuto car celui ci fonctionne aussi pour Debian.
    Voici une url pour récupérer les pilotes : http://code.google.com/p/kyosls/downloads/detail?name=AR81Family-linux-v1.0.1.14.tar.gz&can=2&q=

    Une fois l’installation fait, n’oubliez pas de configurer vos interfaces dans /etc/network/interfaces pour qu’il up automatiquement eth0 si vous avez fait l’install via wlan0.

  1. Pas encore de trackbacks

Anti-Spam Quiz:

antibot * Time limit is exhausted. Please reload the CAPTCHA.

54.161.108.158